Wednesday, July 28, 2010

Summary Router Command

Salam...

Disini ada beberapa router command yg bleh digunakan ketika mengendalikan router cisco...

Cisco Router Configuration Commands

Requirement

Cisco Command

Set a console password to cisco

Router(config)#line con 0
Router(config-line)#
login
Router(config-line)#
password cisco

Set a telnet password

Router(config)#line vty 0 4
Router(config-line)#
login
Router(config-line)#
password cisco

Stop console timing out

Router(config)#line con 0
Router(config-line)#
exec-timeout 0 0

Set the enable password to cisco

Router(config)#enable password cisco

Set the enable secret password to peter.

This password overrides the enable password and is encypted within the config file

Router(config)#enable secret peter

Enable an interface

Router(config-if)#no shutdown

To disable an interface

Router(config-if)#shutdown

Set the clock rate for a router with a DCE cable to 64K

Router(config-if)clock rate 64000

Set a logical bandwidth assignment of 64K to the serial interface

Router(config-if)bandwidth 64
Note that the zeroes are not missing

To add an IP address to a interface

Router(config-if)#ip addr 10.1.1.1 255.255.255.0

To enable RIP on all 172.16.x.y interfaces

Router(config)#router rip
Router(config-router)#
network 172.16.0.0

Disable RIP

Router(config)#no router rip

To enable IRGP with a AS of 200, to all interfaces

Router(config)#router igrp 200
Router(config-router)#
network 172.16.0.0

Disable IGRP

Router(config)#no router igrp 200

Static route the remote network is 172.16.1.0, with a mask of 255.255.255.0, the next hop is 172.16.2.1, at a cost of 5 hops

Router(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.1 5

Disable CDP for the whole router

Router(config)#no cdp run

Enable CDP for he whole router

Router(config)#cdp run

Disable CDP on an interface

Router(config-if)#no cdp enable



Cisco Router Show Commands

Requirement

Cisco Command

View version information

show version

View current configuration (DRAM)

show running-config

View startup configuration (NVRAM)

show startup-config

Show IOS file and flash space

show flash

Shows all logs that the router has in its memory

show log

View the interface status of interface e0

show interface e0

Overview all interfaces on the router

show ip interfaces brief

View type of serial cable on s0

show controllers 0 (note the space between the 's' and the '0')

Display a summary of connected cdp devices

show cdp neighbor

Display detailed information on all devices

show cdp entry *

Display current routing protocols

show ip protocols

Display IP routing table

show ip route

Display access lists, this includes the number of displayed matches

show access-lists

Check the router can see the ISDN switch

show isdn status

Check a Frame Relay PVC connections

show frame-relay pvc

show lmi traffic stats

show frame-relay lmi

Display the frame inverse ARP table

show frame-relay map




Cisco Router Basic Operations

Requirement

Cisco Command

Enable

Enter privileged mode

Return to user mode from privileged

disable

Exit Router

Logout or exit or quit

Recall last command

up arrow or

Recall next command

down arrow or

Suspend or abort

and and 6 then x

Refresh screen output

Compleat Command

TAB




Cisco Router Copy Commands

Requirement

Cisco Command

Save the current configuration from DRAM to NVRAM

copy running-config startup-config

Merge NVRAM configuration to DRAM

copy startup-config running-config

Copy DRAM configuration to a TFTP server

copy runing-config tftp

Merge TFTP configuration with current router configuration held in DRAM

copy tftp runing-config

Backup the IOS onto a TFTP server

copy flash tftp

Upgrade the router IOS from a TFTP server

copy tftp flash



Cisco Router Debug Commands

Requirement

Cisco Command

Enable debug for RIP

debug ip rip

Enable summary IGRP debug information

debug ip igrp events

Enable detailed IGRP debug information

debug ip igrp transactions

Debug IPX RIP

debug ipx routing activity

Debug IPX SAP

debug IPX SAP

Enable debug for CHAP or PAP

debug ppp authentication

Switch all debugging off

no debug all

undebug all

Friday, July 23, 2010

Asas pengenalan router cisco.

Salam,

ni ada sedikit pengetahuan tentang router cisco yang very da basic. sama2 la kite kongsi ye..


Basic 1:

Mula start router Cisco.

------------------------------------------------------------------------------------------------
--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]:
Press RETURN to get started!

------------------------------------------------------------------------------------------------

Note: Boleh pilih yes or no
Prefer ko amik no sebab ko bleh configure sendiri without wizard

Basic 2:

Enter, akan keluar Router>
Masukkan command di bawah utk enable kan console
------------------------------------------------------------------------------------------------
Router>enable
Router#

------------------------------------------------------------------------------------------------

Basic 3

Check the previous configuration/current configuration, using command show run (sh run -- shortcut)

Cth:
------------------------------------------------------------------------------------------------
Router#show run
Building configuration...

Current configuration : 211 bytes
!
version 12.2
no service password-encryption
!
hostname Router
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
ip classless
!
!
!
--More--
------------------------------------------------------------------------------------------------


Basic 4

Bagi membolehkan configuration dilakukan di terminal, masukkan command configure terminal (config t -- shortcut).

Cth:
------------------------------------------------------------------------------------------------
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#

Basic 5 :-

Rename mana-mana routers.

******************************************************8
command - hostname

Cth:
------------------------------------------------------------------------------------------------
Router#enable

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Penang(config)#
Router(config)#hostname Penang
Penang(config)#

------------------------------------------------------------------------------------------------


Basic 6:-

As we know, setiap routers mempunyai tiga interfaces:-

1. console

2. fastethernet/ethernet (mengikut model router cisco)

3. serial (connection kepada NT)
Setiap fastethernet 0/0 bagi setiap routers yang disambungkan pada switch perlu enable.

interface fastethernet 0/0 (int fa0/0 - shortcut)
no shutdown (no shut - shortcut)

------------------------------------------------------------------------------------------------
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Klang(config)#
Klang(config)#interface fastethernet 0/0
Klang(config-if)#no shut
------------------------------------------------------------------------------------------------
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Basic 7

Set IP address pada interfaces

cth klu nk ltk ip address kt stiap (f/a0/0)
------------------------------------------------------------------------------------------------
Klang(config)#interface fastethernet 0/0
Klang(config-if)#ip add 192.168.1.1 255.255.255.0
Klang(config-if)#no shut

------------------------------------------------------------------------------------------------
klu nk ltak ip address kt serial (se0/0)
------------------------------------------------------------------------------------------------
Klang(config)#interface se0/0
Klang(config-if)#ip add 192.168.2.1 255.255.255.0
Klang(config-if)#clock rate 64000 (klu serial cable tu DTE kot.. ehehe)
Klang(config-if)#no shut

------------------------------------------------------------------------------------------------

Basic 8

Set IP route

Cth: Router Klang ke router Penang(192.168.2.2 255.255.255.0).


------------------------------------------------------------------------------------------------
Klang(config)#ip route 192.168.2.2 255.255.255.0 192.168.2.1

------------------------------------------------------------------------------------------------

Basic 9:

Summary interface dalam router

------------------------------------------------------------------------------------------------

Klang#sh ip int brie

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 10.12.6.254 YES NVRAM up up

FastEthernet0/1 unassigned YES NVRAM administratively down down

BRI0/0/0 unassigned YES NVRAM up up

Serial0/1/0 58.139.174.106 YES NVRAM up up

Dialer2 unassigned YES NVRAM standby mode down

------------------------------------------------------------------------------------------------

Basic 10:

Status backup ISDN:

------------------------------------------------------------------------------------------------

Klang#sh isdn st

Global ISDN Switchtype = basic-net3

ISDN BRI0/0/0 interface

dsl 0, interface ISDN Switchtype = basic-net3

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 81, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

Total Allocated ISDN CCBs = 0

------------------------------------------------------------------------------------------------

Command lain untuk backup ISDN

#sh isdn actà untuk tgk status ISDN yg running ketika least/serial line down

#sh isdn hisà untuk tgk history ISDN selepas least line up

#isdn test call int bri0/0/0 0193903554 à untuk test call dri router.

Basic 11:

Check environment dlm router.

------------------------------------------------------------------------------------------------

FAMIP-UMA-CE01-MC901>SH ENVI

Main Power Supply is AC

Fan 1 OK

Fan 2 OK

Fan 3 OK

System Temperature: 34 Celsius (normal)

Environmental information last updated 00:00:19 ago

------------------------------------------------------------------------------------------------

Basic 12:

Testing connection(ping test)

------------------------------------------------------------------------------------------------

Klang#ping 192.168.3.4

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.3.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms

------------------------------------------------------------------------------------------------

Trace route. Perjalanan data hingga ke destinasi(58.139.164.70)

------------------------------------------------------------------------------------------------

KDRMA-01A-CE01-PUJ01#traceroute 58.139.164.70

Type escape sequence to abort.

Tracing the route to 58.139.164.70

1 58.139.157.193 0 msec 0 msec 4 msec

2 58.139.164.69 [AS 23736] 0 msec 0 msec 4 msec

3 58.139.164.70 [AS 23736] 8 msec * 4 msec

------------------------------------------------------------------------------------------------



stakat tu la dulu ye...nnt klu ada mase dan kerajinan kite sam bung balik.

Thursday, July 22, 2010

CCNA

Salam..

CCNA (Cisco Certified Network Associate) adalah professional certificate untuk network yang di keluarkan oleh CISCO. Cert ini merupakan level pertama di dalam cerificate yang cisco keluarkan. Seterusnya akan ada CCNP dan CCIE.

Latihan untuk exam CCNA: CCNA Practice Test

E-Book CCNA for Dummies: Here

Getting started!!

Salam.dah lama aku tinggalkan hobi berbloging nih..so ni adalah permulaan daripada yang akan mendatang..

sekian~